バージョンアップ履歴

ToyStudio/MechaStudioと関連ページについてのバージョンアップの履歴です。

Ver.内容
1.7.0.4ライセンス未登録で「MechaStudio」を起動すると、ファイル保存以外の全機能が有効な「体験モード」になるように仕様変更。前バージョンまではライセンス未登録ではToyStudioと同機能だった。
1.7.0.4ToyStudioのメインウィンドウの表示が「MechaStudio」になっていたのを修正。
1.7.0.3マテリアル ウィンドウの「表示」の欄で「表面」「両面」「裏面」が選べるようになった。
1.7.0.3マテリアル ウィンドウの「表示」が「両面」の場合、MQOファイルのマテリアルでは「両面表示」で入出力されるようになった。
1.7.0.3TOYファイル バージョンを「27」に更新。
1.7.0.2 ex2mqoファイル出力およびvidroレンダリング機能に対して、モーフィングによる形状変更が反映されなかった不具合を修正。
1.7.0.2 exメタセコイアの「材質」で「両面表示」に設定したMQOファイルのマテリアルが正常に読み込まれない不具合の修正。
1.7.0.2「編集」メニューの「元に戻す」「やり直し」のコマンド名がおかしくなっていた不具合の修正。
1.7.0.2「ツール」メニューの「オプション」ダイアログの「全般」タブに、『IK拘束の「アタッチ」をONにする』オプションを追加。IK拘束の作成時に「アタッチ」をONにするかどうかを設定できるようになった。
1.7.0.2「ツール」メニューの「オプション」ダイアログの「全般」タブに、『1ボーンのIK拘束のIKタイプを「自在」にする』オプションを追加。1ボーンのIK拘束の作成時にIKタイプを「自在」にできるようになった。
1.7.0.2IK拘束の新しい「IKタイプ」として「自在面」タイプを追加。各ジョイントがスタート→エンド ジョイントで規定される平面上を動き、IKハンドルの角度に応じてツイスト回転するIKタイプで、FBXファイルの「Single Chain Solver」の動作と互換性がある。
1.7.0.2TOYファイル バージョンを「26」に更新。
1.7.0.2「ヘルプ」メニューの「バージョン情報」ダイアログで、対応するTOYファイルのバージョンを表示するようにした。
1.7.0.2IK拘束の「極ベクトル」の扱いを、「スタート ジョイントの親の座標系」から、「IKハンドルの親の座標系」に変更。
1.7.0.21ボーンのIK拘束のデフォルトの極ベクトルが、スタート ジョイントの親ジョイントを含む面上に来るようにした。
1.7.0.2FBXファイルの書き出しでIK拘束の「ツイスト」の値が出力されるようにした。
1.7.0.2FBXファイルの書き出しで、1ボーン(2ジョイント)のIK拘束は必ず「Single Chain Solver」タイプで出力されるようにした。FBX Converterで1ボーンの「Rotation Plane Solver」タイプのIK拘束が、不定なツイスト回転をすることに対処。
1.7.0.2FBXファイルの読み込みで、IK拘束の「ツイスト」の値が読み込まれるようにした。
1.7.0.2FBXファイル読み込みで、IK拘束の「アタッチ」がOFFになるようにした。
1.7.0.2当サイトのメイン メニューに、「リグ入門」を追加。リグを使ったアニメーションの作成方法や、リグ自体の作成方法を解説。
1.7.0.1 ex2サイトURL更新に伴う、試用ライセンスの登録・認証処理の修正。
1.7.0.1 ex拘束作成時のエラー チェックの不具合を修正。
1.7.0.1 ex拘束関連の処理の全般的な改良。
1.7.0.1FBXファイル等の読み込みダイアログに「シェイプ名のモーフ ターゲットを探す」オプションを追加。モーフ ベースのシェイプと名前が同じで、モーフ ベースとポリゴンの構造が一致するオブジェクトを探して、モーフ ターゲットとして割り当てることができるようになった。
1.7.0.1FBXファイル等の読み込みダイアログに「シェイプ名のモーフ ターゲットを作成」オプションを追加。モーフ ベースのシェイプと名前が同じで、モーフ ベースとポリゴンの構造が一致するオブジェクトを作成し、モーフ ターゲットとして割り当てることができるようになった。
1.7.0.1FBXファイル等の書き込みダイアログに「モーフ ターゲットのポリゴンデータを出力しない」オプションを追加。ファイルを読み込む側でモーフ ターゲットを参照する必要がない場合、出力データを小さくできるようになった。
1.7.0.1モーフを含むアニメーション キーのコピーを行なうと、アプリケーションが落ちる不具合の修正。
1.7.0.1アニメーション キーの貼り付けの際に表示される、「アニメーション キーの張り付け」ダイアログに「モーフ ベース」の欄を追加。モーフィングのアニメーション キーのコピー/張り付けができるようになった。
1.7.0.1モーフ ターゲットとなっているオブジェクトを削除してアンドゥを行うと、アプリケーションが落ちる不具合の修正。
1.7.0.1「OBJファイルの書き込み」ダイアログの「頂点を共有」の チェックを外すと、モデルによってはアプリケーションが落ちる不具合の修正。
1.7.0.1ポリゴンを持たずNURBSカーブのみで構成されるオブジェクトを含むFBXファイルの読み込み時に、アプリケーションが落ちる不具合の修正。
1.7.0.1トピックの「3 FBXファイルの入出力」にモーフィングについての説明を追加。
1.7.0.0 ex2IK以外のコンストレイントを使用したFBXファイルの読み込み時に、MachaStudioが落ちる場合がある不具合の修正。
1.7.0.0 exモーフ ウィンドウの右側のエリアが初回表示の際に描画されない不具合を修正。
1.7.0.0 ex不明なタイプのマテリアルを使用したFBXファイルの読み込み時に、MechaStudioが落ちる場合がある不具合の修正。
1.7.0.0マウスによる図形の選択方法に、従来の「矩形選択」に加えて「投げ縄選択」を追加。
1.7.0.0「スムーズ スキニング」コマンドに「既存のボーン情報を適用」オプションを追加。既存のスキン メッシュのボーン情報をそのまま使って、新規のスキニングが可能になった。
1.7.0.0「ボーン参照をセット」コマンドに「既存のボーン情報を適用」オプションを追加。既存のスキン メッシュのボーン情報をそのまま使って、ボーン参照をセットできるようになった。
1.7.0.0マテリアル ウィンドウの各スライダーのドラッグ終了時に3Dウィンドウの表示が更新されていたが、ドラッグ中に更新されるようにした。
1.7.0.0タイムライン バーの「キーの表示」のサブメニューの「オブジェクト」等のメニューが、キーが存在しない場合でも無効にならないようにした。
1.7.0.0カメラが存在するシーンにおいて、カメラを階層内で移動した際にカレント カメラが更新されず、ファイル書き込みでアプリケーションが落ちる不具合を修正。
1.7.0.0ウェイト ペイント ツールで、F1キーを押しても対応するヘルプ記事が表示されなかった不具合を修正。
1.7.0.0TOYファイル、TOPファイルの読み込みで、カレント サウンド チャンネルが正常に読み込まれなかった不具合を修正。
1.7.0.0TOYファイル、TOPファイルのバージョンを「25」に更新。
1.7.0.0拡張機能版が「ToyStudio Advance」から別エディションの「MechaStudio」に更新され、機能のパッケージングが変更された。
1.7.0.0拡張機能版に含まれていた「メッシュのインポート」コマンドを無償版に移動。
1.7.0.0無償版に含まれていた「拘束(コンストレイント)」関連ツールを拡張機能版に移動。
1.7.0.0拡張機能版のオブジェクト パネルの右クリック メニューに「モーフィング」コマンドを追加。モーフィングが実行できるようになった。
1.7.0.0拡張機能版の「表示」メニューの「ウィンドウ」のサブメニューに「モーフ ウィンドウ」を追加。モーフィングについての各種設定が編集できるようになった。
1.7.0.0旧拡張機能版「ToyStudio Advace」のユーザー ライセンスはそのまま新拡張機能版「MechaStudio」のユーザー ライセンスとして引き継がれる仕様になった。
1.7.0.0拡張機能版が正式にPayPalで購入できるようになった。
1.7.0.0拡張機能版が、ライセンスの購入者のみが使用するマシンであれば3台までのマシンで使用できるようになった。
1.7.0.0チュートリアルに「4-1 モーフィング1(モーフ ベースの準備)」を追加。
1.7.0.0チュートリアルに「4-2 モーフィング2(モーフ ターゲットの作成)」を追加
1.7.0.0チュートリアルに「4-3 モーフィング3(モーフィングの実行)」を追加
1.6.3.7「FBXファイルの書き込み」ダイアログに「マテリアル カラーを拡散光として出力」チェックを追加。Unity用FBXファイルで、マテリアル カラーが正確に出力できるようになった。
1.6.3.7「FBXファイルの書き込み」ダイアログに「ポリライン表示のメッシュ以下を動かさない」チェックを追加。リグを使用したモデルで、不用なアニメーション キーの出力を省くことができるようになった。
1.6.3.7メタセコイア4で作成された、頂点数が4を超えるポリゴンを含むMQOファイルの読み込みに対応。
1.6.3.7正射影のMQOファイルを読み込んだ際に、視野がガクガクぶれることがある不具合を修正。
1.6.3.7ウェイトペント時、「スムージング」後、「置き換え」に変えても「ペイント値」の箇所が操作できなくなることがある不具合を修正。
1.6.3.7大きなサイズのToyファイル(420MB程度)の書き込み中に、アプリケーションが落ちる不具合を修正。
1.6.3.7拘束の存在するシーンにおいて、ゴーストを表示した状態で「移動ツール」等で操作を行うとアプリケーションが落ちる不具合を修正。
1.6.3.7アニメーション再生中にカメラ ウィンドウでカメラ位置を変更すると、拘束が機能しないでアニメーション再生される不具合を修正。
1.6.3.7「移動ツール」等でドラッグ中に「Enter」キーが押されると、操作が中途半端な状態で終了してします不具合の修正。
1.6.3.6正射影表示の際に、大きなシーンにおいて小さなオブジェクトを拡大すると、視野の回転で視野がガクガクぶれるバグを修正。
1.6.3.6Xファイルの書き込みダイアログで、「カレント アニメーションのみを出力」オプションを追加。
1.6.3.6「ボーン ウェイトのミラー コピー」コマンドにおいて、これまでは位置の重複する頂点についてはウェイトをコピーできなかったが、接続する面の他の頂点位置を参照して、可能な限りコピーできるように改良した。
1.6.3.6ウェイト ペイント機能で、白く塗りつぶせない黒い頂点が表示されるバグを修正。
1.6.3.6ポリゴンの頂点を移動させた後に、選択ボックスの位置が更新されない不具合を修正。
1.6.3.6オブジェクト・パネルでオブジェクトの階層を移動させた際に、オブジェクト・ウィンドウの「移動」や「回転」の数値が更新されないバグを修正。
1.6.3.6ポリライン表示のメッシュ オブジェクトで隠れたオブジェクトが、クリックで選択できないバグを修正。
1.6.3.5ウェイト ペイント機能で、ペイント対象モデルの部位が視点よりも手前に回り込んでいる場合に、マウスによるオブジェクトの選択やペイントが適切に行われない不具合を修正。
1.6.3.5FBXファイル等の書き込み機能で、オブジェクトのオイラー角の回転順が出力されなくなっていた不具合の修正。
1.6.3.5「FBXファイル」等の書き込みダイアログで、「オイラー角を規定」を追加。オイラー角の回転順序が固定されているシステム用に、回転順序とアニメーションの回転キーを変換して出力できるようになった。
1.6.3.5「FBXファイル」等の書き込みダイアログで、「オブジェクトの全てのキーをリサンプル」をONにすると、「球面線形補間をリサンプル」が無効になっていたが、これらを両立できるようにした。
1.6.3.5「FBXファイル」等の読み込みダイアログで、「ピボット変換レート」を「フレーム単位」に変更。読み込みの際のフレームの単位指定ができるようになった。また、この値はアニメーションのピボット変換が必要な際のフレーム レートとしても使用される。
1.6.3.5「オブジェクト ウィンドウ」の「制限」タブで、「移動」などのX、Y、Zの最大値の入力が正常に行われないバグの修正。
1.6.3.5オブジェクト パネルでジョイントをドラッグして移動し、アンドゥーすると、ジョイントの親子表示が元に戻らないことがあるバグの修正。
1.6.3.5「エイム拘束」の「ワールド アップ ターゲット」のオブジェクトが指定されていて、チェックをON/OFFに切り替えた際に、拘束が実行されない場合があったバグの修正。
1.6.3.4「IKハンドル ツール」でデフォルトで作成されるIKのタイプを、他の拘束との連携などを考慮し「回転面Flex」から「回転面」に変更した。
1.6.3.4ジョイントを選択した状態で平面や立方体等を作成する際に、「ポリゴン選択 モード」の場合のみそのジョイントの影響範囲となり、それ以外の場合は新規のメッシュ オブジェクトとなるようにした。
1.6.3.4各種拘束機能における位置の拘束処理において、拘束ターゲットのピボットが反映されないバグを修正した。
1.6.3.4FBXファイル等の出力ダイアログにおいて、「ピボットを座標値にマージ」チェックをデフォルトでOFFに変更した。
1.6.3.4オブジェクト パネルでジョイントの階層位置を移動したり元に戻したりする際に、ジョイントをつなぐボーンの表示が更新されないバグを修正した。
1.6.3.3「ペアレント拘束」ツールを追加。ペアレント拘束が作成できるようになった。
1.6.3.3FBXファイルの入出力機能において、ペアレント拘束の入出力に対応した。
1.6.3.3IK以外の拘束機能において、前バージョンではパラメータの拘束やオフセットをローカル座標系で行っていたのを、FBX形式と同様にワールド座標系で行うように変更した。
1.6.3.3オブジェクト ウィンドウの各種の「拘束」タブで、「オフセット」のON/OFFが「アクティブ」のON/OFFとしてセットされてしまうバグを修正。
1.6.3.3ヘルプのメイン ツールバーのページに拘束の欄がなかったのを加筆。
1.6.3.3toyファイル、topファイルのバージョンを24に更新。
1.6.3.2「位置拘束」、「回転拘束」、「エイム拘束」、「スケール拘束」ツールを追加。拘束(コンストレイント)が作成できるようになった。
1.6.3.2拘束を持つオブジェクトを選択すると、IKハンドルと同様にデフォルトで青い選択枠が表示されるようになったため、「ツール」メニューの「オプション」ダイアログの「表示」タブの「カラー」の項目で、「選択IK」を「選択拘束」に変更した。
1.6.3.2オブジェクト ウィンドウの「IKハンドル」タブの名称を「IK拘束」に変更した。
1.6.3.2オブジェクト ウィンドウの「IK拘束」タブの「極ベクトルの球面線形補間」チェックの名称を「方向ベクトルの球面線形補間」チェックに変更した。
1.6.3.2オブジェクト ウィンドウの「IK拘束」タブの「極ベクトル」の「セット」ボタンが不要になり、数値が直接入力されるようになった。
1.6.3.2オブジェクト ウィンドウの「IK拘束」タブに「削除」ボタンを追加。IK拘束自体を削除できるようになった。
1.6.3.2オブジェクト パネルの右クリック メニューの「以下を設定」のサブメニューの「IKハンドルをアクティブにする」を「IKハンドル/拘束をアクティブにする」に変更。IKハンドルに加え、拘束の一括してアクティブにできるようになった。「IKハンドルを非アクティブにする」についても同様に変更。
1.6.3.2オブジェクト ウィンドウに「制限」タブを追加。3Dウィンドウにおけるオブジェクトの「移動」、「回転」、「スケール」の操作に制限を設定できるようになった。
1.6.3.2「FBXファイル」等の書き込みダイアログで、「IKをベイク」を「拘束をベイク」に変更。IKのみではなく各種拘束についても、そのまま出力するか拘束をベイクして出力するかが選択できるようになった。
1.6.3.2「FBXファイル」等の書き込みダイアログで、「拘束をベイク」がOFFの場合、FBX形式のIKコンストレイント、位置コンストレイント、回転コンストレイント、エイム コンストレイントが出力できるようになった。
1.6.3.2「FBXファイル」等の書き込みダイアログで、「IKハンドルをアタッチ」チェックが、「IKをベイク」がONじゃない場合でも有効になった。
1.6.3.2FBXファイルの読み込みで、FBX形式のIKコンストレイント、位置コンストレイント、回転コンストレイント、エイム コンストレイントが読み込めるようになった。
1.6.3.2FBXファイルの書き込みで、FBX形式のリミット情報が出力できるようになった。
1.6.3.2FBXファイルの読み込みで、FBX形式のリミット情報が読み込めるようになった。
1.6.3.2オブジェクトの「直接移動」、「直接回転」、「ツイスト回転」モードにおいて、マウスのドラッグ操作の開始時ではなく終了時に対象オブジェクトが選択されるようになった。
1.6.3.2「オブジェクト」ウィンドウの「メッシュ」タブの「ポリライン表示」がONの場合、オブジェクトの「面」をクリックしても選択できないようにした。
1.6.3.2「スケール」ツール、「IKハンドル」ツールのアイコンを少し大きめに変更した。
1.6.3.2「メッシュのインポート」ダイアログで、下部のチェック ボックスがリサイズに追従しないバグを修正。
1.6.3.2toyファイル、topファイルのバージョンを23に更新。
1.6.3.2ジョイントの影響範囲のポリゴンが参照しているマテリアルを削除するとアプリが落ちる不具合を修正。
1.6.3.1「FBXファイル」等の書き込みダイアログに、「スムージング グループを出力」オプションを追加。スムージング グループが必須のアプリケーションに対応した。
1.6.3.1「FBXファイル」等の書き込みダイアログに、「テクスチャをシングル レイヤーで出力」オプションを追加。シングル レイヤーのテクスチャしか読み込めないアプリケーションに対応した。
1.6.3.1「FBXファイル」等の書き込みダイアログに、「カレント アニメーションのみを出力」オプションを追加。カレント アニメーションのみをFBXファイルにセットできるようになった。
1.6.3.1「FBXファイル」等の書き込みダイアログに、「オブジェクトの全てのキーをリサンプル」オプションを追加。オブジェクトの全てのアニメーション キーをリサンプルして出力できるようになった。
1.6.3.1「FBXファイル」等の書き込みダイアログの「球面線形補間をベイク」オプションの名前を、「球面線形補間をリサンプル」に変更。
1.6.3.1FBXファイルの読み込み処理で、テクスチャが絶対パスで指定されている場合でも、可能なら相対パスで読み込むようにした。
1.6.3.1トピックスに「17 Unreal Development Kit (UDK)用FBXファイルの出力」を追加した。
1.6.3.1トピックスの「15 POSE STUDIO用FBXファイルの作成」を更新した。
1.6.3.0ソフトウェア名を「ToyStudio」から「TOYSTUDIO」と大文字化した。
1.6.3.0「ボーンの追加/ウェイトの再セット」ダイアログに「チェックされているボーンのウェイト ブレンド率」を追加。追加するボーンのウェイト ブレンド率を調整できるようになった。
1.6.3.0「ボーンの追加/ウェイトの再セット」等のダイアログで、「参照するボーン」に表示されているボーンのグレー表示がマウス移動で通常表示に戻る不具合を修正。
1.6.3.0「~ファイルの読み込み」ダイアログに「グリッド サイズを自動調整」チェックを追加。ネイティブ以外のファイルの読み込み時に、グリッド サイズを自動調整するかデフォルト サイズにするかを選択できるようになった。
1.6.3.0「~ファイルの読み込み」ダイアログに「ジョイントやヌル等の表示半径を自動調整」チェックを追加。ネイティブ以外のファイルの読み込み時に、ジョイントやヌル等の表示半径を自動調整するかデフォルト サイズにするかを選択できるようになった。
1.6.3.0「シーン設定」ダイアログの「全般」タブの下部に「デフォルト値設定」ボタンとそのダイアログを追加。グリッドと表示半径についてのデフォルト値を設定できるようになった。
1.6.3.0「シーン設定」ダイアログの「全般」タブの「ライト」の表示半径がTOYファイルに保存されていなかったバグを修正。
1.6.3.0「シーン設定」ダイアログの「表示」タブの「メッシュをカメラから遠い順で描画」は、メタセコイアでの表示に合わせるため、MQOファイルではデフォルトでOFFに変更した。
1.6.3.0拡張機能において、「レンダー」メニューに「vidro ウィンドウ」を追加。vidroによるレンダリングに対応した。
1.6.3.0「マテリアル」ウィンドウの下部に「マテリアル情報」ボタンを追加。クリックすると、オブジェクトからの参照情報が表示できるようになった。
1.6.3.0「マテリアル」ウィンドウの下部に「レンダラー」タブを追加。レンダラー用のパラメータを設定できるようになった。
1.6.3.0「マテリアル」ウィンドウの「テクスチャ」ダイアログで画像ファイルを開く場合、デフォルトで「対応するすべてのファイル」がリストアップされるようになった。
1.6.3.0「ツール」メニューの「オプション」ダイアログに「レンダラーで既存のプレビュー画像を読み込む」を追加。「vidro ウィンドウ」のプレビューにおいて、既存のプレビュー画像を読み込むかどうかを設定できるようになった。
1.6.3.0「ツール」メニューの「オプション」ダイアログに「プレビューのグローバル イルミネーション」を追加した。「vidro ウィンドウ」のプレビューにおける、「グローバル イルミネーション」のピクセルあたりのサンプル数を設定できるようになった。
1.6.3.0FBXファイルの読み込みで、マテリアルの透明度カラーが(0,0,0)の場合は透明度を0として読み込むようにした。
1.6.3.0「オブジェクト ウィンドウ」の「ライト」タブを「+」ボタンで開いた際に、表示内容が更新されない不具合を修正。
1.6.3.0連番MQOファイルの出力機能等で、指定したフレーム範囲ではなく、アニメーションの再生範囲で出力してしまう場合があるバグの修正。
1.6.3.0TOY、TOPファイルのバージョンを22に更新。
1.6.3.0MQOファイルの保存において、パースペクティブ射影の視野角が忠実に出力されるように修正。
1.6.3.0アニメーション等の出力時に、プログレス ウィンドウのタイトルバーに初期のパーセンテージが表示されないバグを修正。
1.6.3.0ToyStudio SDKのHTMLドキュメントを更新。ドキュメントをDoxygen1.8.3で生成した。
1.6.2.9タイムライン バーの右クリック メニューに「次のキー」(Ctrl+→)、「手前のキー」(Ctrl+←)を追加した。
1.6.2.9DAEファイル、3DSファイルの入出力機能で、テクスチャ ファイルのパスが正常に入出力できない不具合の修正。
1.6.2.9DAEファイルの出力時に、マテリアルのセットされているポリゴンとセットされてないポリゴン(デフォルト マテリアルで表示)ポリゴンがオブジェクト内に混在しているとFBXライブラリー内で落ちるので、確認メッセージを表示して出力をキャンセルするようにした。
1.6.2.9ポリゴンの形状によって、マウス クリックによるポリゴンの選択が無効になる場合がある不具合の修正。
1.6.2.8オブジェクト パネルでボーンを同じ階層内でドラッグして移動する場合に、スキニングを完全に維持できるようになった。
1.6.2.8タイムライン バーのタイムラインで、アニメーション全体ではなく、現在選択されたオブジェクト等のアニメーション キーのみを表示するようになった。これはグラフ ウィンドウと同様の表示方法。
1.6.2.8タイムライン バーに右クリック メニューが表示し、アニメーション キーのコピペや表示設定等が行えるようになった。これに伴い、メイン メニューの「アニメーション」トップ メニューは廃止した。
1.6.2.8タイムライン バーの右クリック メニューの「キーの編集」のサブメニューとして、「セット」、「切り取り」、「コピー」、「貼り付け」、「削除」、「すべて削除」、「アニメーション全体のキーを削除」を追加し、ショートカット キーにも対応した。タイムライン上でキーの編集ができるようになった。
1.6.2.8タイムライン バーの右クリック メニューの「キーの表示」のサブメニューとして、「オブジェクト」、「サウンド」、「シーン」、「すべて」を追加し、Shift(追加)、Ctrl(反転)キーの同時押しにも対応した。タイムライン上でアニメーション キーの表示項目が設定できるようになった。
1.6.2.8タイムライン バーの右クリック メニューに「連続再生」を追加し、アニメーションの連続再生の切り替えができるようになった。
1.6.2.8タイムライン バーの右クリック メニューに「グラフ ウィンドウ」を追加し、グラフ ウィンドウの表示切り替えができるようになった。
1.6.2.8タイムライン バーの「現在のフレーム」の強調表示の幅を狭くして分かりやすくした。
1.6.2.8グラフ ウィンドウでアニメーション キーの編集や削除などを行った際に、左側のツリー ペインがデフォルトの表示状態にリセットされないようにした。
1.6.2.8「カメラ選択」のアニメーション キーで、選択カメラが「NULL」の場合はキーが作成できなかったが、キーの値を0として作成できるようにした。
1.6.2.8カメラ ウィンドウの選択カメラが「NULL」の場合でも、グラフ ウィンドウで「カメラ選択」のアニメーション キーが表示されるようにした。
1.6.2.8ヘルプの「タイムライン バー」や「グラフ ウィンドウ」等の項目を大幅に加筆・修正した。
1.6.2.7グラフ ウィンドウの「キー」メニューに「スケーリング」コマンドを追加。Xの範囲指定や、中心とスケールの値でアニメーション キーをスケーリングできるようになった。
1.6.2.7グラフ ウィンドウの下部の「キーセット」ボタンで、X、Y個別の「絶対」値を複数のキーにセットできるようになった。これにより、複数のキーのフレーム番号をまとめて「絶対」値でセットできるようになった。
1.6.2.7グラフ ウィンドウの下部に「全範囲のキー選択」ボタンを追加。全範囲のアニメーション キーを選択できるようになった。
1.6.2.7グラフ ウィンドウでアニメーション キーを他のキーと重複するX値に移動し、「元に戻す」コマンドを実行するとソフトウェアが落ちる不具合を修正。
1.6.2.7グラフ ウィンドウのメニューで「傾き」メニューを「キー」メニューのサブメニューとして「傾きのタイプ」に変更した。
1.6.2.7グラフ ウィンドウの「キー」関連サブメニューをアニメーション キーが選択されていない場合はグレーアウトするようにした。
1.6.2.7「ファイル」メニューの「シーンにインポート」コマンドで、スケールや座標系を変換しても、ポリゴンの表示が変更されないバグを修正。
1.6.2.7「オブジェクト」メニューの「ミラーポーズ」コマンドを、スキニングされていないボーンに対して実行するとソフトウェアが落ちる不具合。
1.6.2.7「MQOファイルの書き込み」ダイアログで、「重複しないオブジェクト名に修正」オプションを追加。ユニークなオブジェクト名で出力できるようになった。
1.6.2.7「MQOファイルの書き込み」ダイアログで、「アニメーションを連番ファイルで出力」オプションをデフォルトでOFFに変更。
1.6.2.7チュートリアルに「15 POSE STUDIO用FBXファイルの作成」を追加。
1.6.2.6「編集」メニューに「選択セットの作成」コマンドを追加。複数のオブジェクトやポリゴンの選択セットを登録できるようになった。
1.6.2.6「編集」メニューの「選択セット ウィンドウ」をクリックすると、選択セット ウィンドウが表示されるようになった。各選択セットをクリックすることで、対象図形をまとめて選択できるようになった。
1.6.2.6「オブジェクト」メニューに「ポーズの作成ポーズ」コマンドを追加。複数のオブジェクトの姿勢をポーズとして登録できるようになった。
1.6.2.6「オブジェクト」メニューの「ポーズ ウィンドウ」をクリックすると、ポーズ ウィンドウが表示されるようになった。各ポーズをクリックすることで、オブジェクトの姿勢をまとめて設定できるようになった。
1.6.2.6グラフ ウィンドウのグラフに現在のフレームを示す縦線が表示されるようになった。
1.6.2.6グラフ ウィンドウのアニメーション キーの「切り取り」コマンドで、グラフの表示が更新されないバグの修正。
1.6.2.6グラフ ウィンドウの「アニメーション キーの貼り付け」コマンドが、「編集」メニューの「元に戻す」/「やり直し」の右に表示されるコマンド名として表示されなかった不具合の修正。
1.6.2.6グラフ ウィンドウのグラフの描画で、ある程度間隔の短いラインを描画しないようにした。
1.6.2.6グラフ ウィンドウでマウスの「右ボタン」+「左ボタン」ドラッグでズームする場合、下部の表示範囲の数値が更新されなかったバグの修正。
1.6.2.6カメラ オブジェクトの名前を変更した際に、カメラ ウィンドウの「選択カメラ」のリスト内の名前が更新されないバグの修正。
1.6.2.6シーン設定ダイアログの「全般」タブの「表示半径」にライトの項目が無かったので追加した。
1.6.2.6「ファイル」メニューの「シーンにインポート」コマンドでメッシュを含まないモデルを読み込んだ場合、シーン サイズの自動調整がうまくいかない不具合の修正。
1.6.2.6AVI、連番BMP、連番MQOファイルの保存ダイアログにおいて、フレーム範囲の初期値をアニメーションのデータ範囲から再生範囲に変更。
1.6.2.6「MQOファイルの書き込み」ダイアログで、「連番ファイル出力」チェックの表記を「アニメーションを連番ファイルで出力」に変更。
1.6.2.6TOYファイルの要素名に“]]>”文字列が使えるようになった。
1.6.2.6FBXファイルのNURBSカーブがヌル オブジェクトではなく、メッシュ オブジェクトのポリラインとして読み込まれるようになった。
1.6.2.6FBXファイルの読み込みで、ポーズ リストが読み込まれるようになった。
1.6.2.6「FBXファイルの書き込み」ダイアログに「ポーズを出力」オプションを追加。
1.6.2.6「FBXファイルの書き込み」ダイアログ等に「アニメーションを出力」オプションを追加。
1.6.2.6「FBXファイルの書き込み」ダイアログ等に「不可視オブジェクトのポリゴン データを出力しない」オプションを追加。
1.6.2.6「FBXファイルの書き込み」ダイアログに「ポリライン表示のポリゴンをNURBSカーブで出力」オプションを追加。
1.6.2.6「Xファイルの書き込み」ダイアログに「アニメーションを出力」オプションを追加。
1.6.2.6「Xファイルの書き込み」ダイアログの「IKをアニメーションに反映」チェックの表記を「IKをベイク」に変更。
1.6.2.6対応OSとして、Windows 7をドキュメントに明記。
1.6.2.5メイン ツール バーに「ポリゴン非表示」 ツールを追加。3D ウィンドウ上でクリックしたポリゴンやポリラインを非表示にできるようになった。
1.6.2.5「ポリゴン」メニューに「ポリゴンを非表示にする」コマンドを追加。選択されたポリゴンやポリラインを非表示にできるようになった。
1.6.2.5「ポリゴン」メニューに「選択ポリゴン以外を非表示にする」コマンドを追加。オブジェクト内の選択されたポリゴンやポリライン以外を非表示にできるようになった。
1.6.2.5「ポリゴン」メニューに「非表示のポリゴンを表示する」コマンドを追加。シーン全体における非表示のポリゴンやポリラインを表示できるようになった。
1.6.2.5FBXファイルの入出力機能において、ポリゴン単位の表示/非表示に対応した。
1.6.2.5「スムーズ シェーディング」ツールで、複数のポリゴンについてレドゥー/アンドゥーできるようになった。
1.6.2.5「フラット シェーディング」ツールで、複数のポリゴンについてレドゥー/アンドゥーできるようになった。
1.6.2.5「マテリアル」ツールで、複数のポリゴンについてレドゥー/アンドゥーできるようになった。
1.6.2.5「表示」メニューの「ジョイント、ヌル、カメラ、ライトを再前面に表示」がONの場合に、再前面でクリックされない場合があったバグの修正。
1.6.2.5「表示」メニューの「ウィンドウ」→「ライト ウィンドウ」をクリックすると、「メッシュ」の表示状態が変更されていたバグの修正。
1.6.2.5TOY、TOPファイルのバージョンを20に更新。
1.6.2.4拡張機能として、オブジェクト パネルの右クリック メニューに「メッシュのインポート」コマンドを追加。既存のボーン ウェイトをできるだけ維持しながら、外部ファイルのメッシュで上書きできるようになった。
1.6.2.4MQO、OBJ、DXF形式のファイル出力において、「頂点座標をそのまま出力」オプションを追加。オブジェクトごとのローカル座標系を持たないファイル形式において、メッシュ自体の形状を出力できるようになった。
1.6.2.4トピックスに「1-13 メッシュのインポート」を追加。「メッシュのインポート」機能を利用した外部モデリング ソフトとの連携方法について記載。
1.6.2.4「アニメーションのインポート」ダイアログに、「名前でオブジェクトを割り当て」オプションを追加。オブジェクトのツリー構造だけではなく、オブジェクトの名前を参照してアニメーションをインポートできるようになった。関連するチュートリアルとして、「2-9 アニメーションのインポート」を更新した。
1.6.2.3MQOファイルのマテリアルの「頂点カラーのON/OFF」フラグがToyファイルに正常に保存されないバグの修正。
1.6.2.3FBX、DAEファイル等の出力において、球面線形補間およびIKを使用しているアニメーションを「球面線形補間をベイク」チェックおよび「IKをアニメーションに反映」チェックの両方をONにして出力した場合、IKがアニメーションの一部のキー フレームにしか反映されないバグを修正。
1.6.2.3ToyStudio、ToyPlayerのアプリケーション実行中のCPUの負荷を軽減した。
1.6.2.3ToyPlayerがフルスクリーン モードで実行中にALT+TABでアプリを切り替えた場合、ウィンドウ モードに戻すようにした。
1.6.2.3ToyStudio、ToyPlayerのアイコンを32ビット カラー、ラージ サイズに対応。
1.6.2.2拡張機能として、「オブジェクト」メニューに「ボーン ウェイトのミラー コピー」コマンドを追加。スキニングされたメッシュの頂点のボーン ウェイトをミラー コピーできるようになった。
1.6.2.2「スムーズ スキニング」、「ボーンを削除」、「ボーンの追加/ウェイトの再セット」コマンドに、「チェックされてないボーンも近接ボーンの算出に使う」オプションを追加。参照するボーンとしてチェックされていないボーンを、頂点の近接ボーンの算出に使うかどうかを設定できるようになった。
1.6.2.1「Xファイルの書き込み」ダイアログに「Mesh要素の名前を出力」オプションを追加。Xファイルの「Mesh」要素にオブジェクト名と同じ名前を出力できるようになった。
1.6.2.1「Xファイルの書き込み」ダイアログに「不可視オブジェクトのポリゴン データを出力しない」オプションを追加。「不可視」になっているオブジェクトについては、ポリゴン データを出力しないようにできるようになった。
1.6.2.1「複製」ダイアログで状況依存ヘルプが起動しないバグの修正。
1.6.2.1「バージョン情報」ダイアログや、インストーラー、ヘルプに使用SDKの著作権表示を明記した。
1.6.2.0に「3-1 かんたん歩行アニメーション」を追加。IKを利用した簡単で本格的な歩行アニメーションの制作方法について解説。
1.6.2.0IKハンドルの作成時に「アタッチ」がデフォルトでONになるように変更した。
1.6.2.0パネルの右クリックメニューの「以下を設定」のサブメニューに「IKハンドルをアクティブにする」、「IKハンドルを非アクティブにする」、「IKハンドルをアタッチする」、「IKハンドルをアタッチしない」を追加。IKハンドルのアクティブおよびアタッチについて、一括設定が可能になった。
1.6.2.0IKハンドルの親となっているメッシュ オブジェクト等を移動した場合に、リンクしているIKが動作しない場合があったバグを修正。
1.6.2.0オブジェクト ウィンドウでジョイントの移動や回転等のパラメータを直接変更した場合に、リンクしているIKが動作しない場合があったバグを修正。
1.6.2.0「.toy」、「.top」ファイルにおいて、IKハンドルの「極ベクトル」の「球面線形補間」パラメータの入出力ができていなかったバグの修正。
1.6.2.0「ミラー ポーズ」コマンドに、「対称オブジェクトを名前で判別」オプションを追加。オブジェクト名の「右」や「左」などの文字列で対称関係を判別できるようになった。
1.6.2.0「ミラー ポーズ」コマンドで、スキニングされたボーンだけではなく、通常のオブジェクトについても「ミラー ポーズ」を利用できるようになった。
1.6.2.0「複製」コマンドに、「名前を変更」オプションを追加。オブジェクト名の「右」や「左」などの文字列を自動的に変更できるようになった。
1.6.2.0「シーン設定」ダイアログで、グリッドのON/OFFがX、Y、Z方向で個別に設定できるようになった。
1.6.2.0「移動」ツールで「グリッドスナップ」が有効な場合、マニピュレータの中央(黄色)のハンドルをドラッグすると、グリッド面上にスナップする仕様になっていたが、この仕様を廃止した。
1.6.2.0F2~F4キーでの視野方向の設定において、現在と反対方向(SHIFTキー使用)への変更がうまく行かない場合があったバグの修正。
1.6.2.0「.toy」、「.top」ファイルのバージョンを19に更新した。
1.6.1.9「オブジェクト」メニューの「ミラー ポーズ」コマンドの不具合を修正。
1.6.1.9「ミラー ポーズ」コマンドのヘルプに「ミラー ポーズに対応するボーン」の項目を追加。正確にミラー ポーズを実行できるボーンの条件について記載。
1.6.1.9トピックスの「9 ミラー ポーズについて」に「ミラー ポーズに対応するボーン」の項目を追加。正確にミラー ポーズを実行できるボーンの条件について記載。
1.6.1.9チュートリアルの「2-1 ボーンの作成」、「2-2 スキニング」、「2-3 ボーン アニメーション」を更新。ミラー ポーズを正確に実行できるモデルの作成に対応した。
1.6.1.9チュートリアルの「2-6 ボーンの追加」を更新。スキニング済みのメッシュに対して、ミラー ポーズに対応するボーンを追加するようにした。
1.6.1.9チュートリアルの「2-7 個別のアニメーションの削除」を更新。編集対象のモデル ファイル等を更新した。
1.6.1.9「回転」ツール使用時の「ツール」 ウィンドウの下部に「オブジェクトのジンバル ロックを回避」チェックを追加。オブジェクトの回転におけるジンバル ロックを回避するかどうか設定できるようになった。
1.6.1.9オブジェクト パネルの右クリック メニューの「以下を設定」のサブメニューに「回転を球面線形補間する」と「回転を球面線形補間しない」を追加。指定オブジェクト以下の球面線形補間の設定を一括して行えるようになった。
1.6.1.9「FBXファイルの書き込み」ダイアログに「アニメーションのベイク」グループを追加。その中に「球面線形補間をベイク」チェックを追加し、球面線形補間のアニメーションを一定周期のオイラー角のキーで出力できるようになった。
1.6.1.9「FBXファイルの読み込み」等のダイアログに「ジョイントを球面線形補間に設定」チェックを追加し。ファイル等の読み込みの際にジョイントを球面線形補間に設定するかどうかを選択できるようになった。
1.6.1.9FBXファイルの入出力機能で、オブジェクトの「回転を球面線形補間」フラグををFBX SDKのKFbxNode::SetUseQuaternionForInterpolation()関連関数で入出力させるようにした。
1.6.1.9球面線形補間におけるオイラー角の算出方法において、これまではそのフレームのオイラー角の補間値にクォータニオンの補間値を反映させていたが、前のキー フレームのオイラー角にクォータニオンの補間値を反映させるように変更した。
1.6.1.9球面線形補間において、これまでは、X、Y、Zのいずれかの回転キーがあるキー フレームの姿勢(クォータニオン)を補間していたが、X、Y、Zの全ての回転キーがあるキー フレームの姿勢を補間するようにした。
1.6.1.9トピックスに「11 アニメーションにおける回転の補間」を追加。アニメーションにおけるオイラー角の補間と球面線形補間の機能について説明。
1.6.1.9「オブジェクト」メニューの「ミラー/再分割曲面のフリーズ」コマンドおいて、「ミラーのフリーズ」ダイアログを表示するようにした。このダイアログに「ミラーの中心から指定距離以内にある頂点を重複させない」チェックと「ミラーの中心からの距離」の数値を追加。ミラーの中心から指定距離以内にある頂点について、フリーズの際に重複して定義しないようにできるようになった。
1.6.1.9「オブジェクト」メニューの「複製」コマンドのレドゥーがうまく行かない場合があったバグの修正。
1.6.1.9ジョイント ツールで、新規ジョイントの入力位置が乱れる場合があった不具合を修正。
1.6.1.9「オブジェクト」メニューの「スキニングをクリア」コマンドが、「ブランチ選択」モードでグレーアウトされていたバグを修正。
1.6.1.9「選択/移動/回転/スケーリング」ツールのヘルプに「直接操作」についての言及とリンクを追記。
1.6.1.8一部のFBXファイルで、アプリ起動後2回目以降の読み込みで正常に読み込まれない不具合を修正。
1.6.1.8ピボットが設定されていて複数のアニメーションを持つFBXファイルの読み込みにおいて、2個目以降のアニメーションのピボット変換ができていなかった不具合の修正。
1.6.1.8FBXファイルの読み込みダイアログで、「ピボット変換レート」の項目を追加。ピボットとアニメーションがセットされたファイルを読み込む場合の、ピボットの変換とアニメーション キーのリサンプリングのフレーム レートを指定できるようになった。
1.6.1.8FBXファイルの出力で、法線ベクトルを面の頂点ごとに忠実に出力できるようになった。
1.6.1.8FBXファイル等の出力ダイアログに「法線ベクトルを共有」チェックを追加し。面で共有された法線ベクトル(スムーズ シェーディング)を出力するか、法線ベクトルを忠実に出力か設定できるようになった。
1.6.1.8FBXファイルの読み込みで、モデルの法線ベクトルの角度から面の各頂点のスムーズ/フラット シエーディングの状態を判別して読み込むように改良。
1.6.1.8FBXファイルの読み込みで、マテリアルの「反射の強さ」が0~1の範囲に制限されて読み込まれていたバグを修正。
1.6.1.8FBXファイルの読み込みで、マテリアルの拡散光のRGBが全て0の場合でも、他の要素からカラー(色相)が読み込めるように改良。
1.6.1.8FBXファイルの読み込みで、頂点のボーン インデックス数が実際の頂点数を越えている不正なデータを読み込んだ場合でもアプリが異常終了しないように改良。
1.6.1.8一部のモデル データにおいて、ポリゴンの表示が白とびする場合があった不具合を修正。
1.6.1.7前回のバージョンアップで生じていた、マテリアルが未設定(デフォルト マテリアル使用)のポリゴン データを表示するとアプリケーションが落ちるバグを修正。
1.6.1.7ポリゴン ツールで、前の入力頂点を含む視野方向平面上に次の頂点が入力されるように改良。
1.6.1.7ポリライン ツールで、前の入力頂点を含む視野方向平面上に次の頂点が入力されるように改良。
1.6.1.7ジョイント ツールで、前の入力ジョイントを含む視野方向平面上に次のジョイントが入力されるように改良。
1.6.1.6透過ポリゴン関連の描画について、「シーン設定」ダイアログの「表示」タブに、「メッシュをカメラから遠い順で描画」チェックを追加。ONの場合、各メッシュ オブジェクトはその原点位置がカメラから遠い順で描画され、OFFの場合、オブジェクトの親子順で描画されるようになった。
1.6.1.6トゥーン シェーダーの「輪郭線不透明度」が表示に反映されないバグの修正。
1.6.1.5「表示」メニューに「アンチエイリアス」を追加。3Dウィンドウ等でアンチエイリアス表示ができるようになった。
1.6.1.5「デバイス」ダイアログに「高品質のアンチエイリアスを使う」チェックを追加。
1.6.1.5「ポリゴン編集 モード」において、ヌルやカメラがグレー表示になっていたバグの修正。
1.6.1.5「ポリゴン編集 モード」において、トゥーン シェーダーを設定したモデルがバインド ポーズにならなかったバグの修正。
1.6.1.5「カメラ ウィンドウ」の十字線表示のON/OFF設定を保存するようにした。
1.6.1.5Windows Vista以降において、3Dウィンドウ等における選択矩形の描画が遅延しないようにした。
1.6.1.4「デバイス」ダイアログの「ハードウェア頂点処理」がOFFの場合、トゥーン シェーディングがおかしくなるバグの修正。
1.6.1.4アプリケーションの起動時間が数分の1になった。
1.6.1.4「表示」メニューの「メッシュ」オブジェクトの表示ON/OFFに対応。
1.6.1.4メタセコイア3.0 Alpha2用のMQOファイルのライト情報の読み込みに対応。
1.6.1.4「強度」が0のライトは、デバイスの光源として無効になるように修正。
1.6.1.4カメラ、ライト等のデータの修正してファイルを閉じる際に、ファイルへの変更を保存するかどうかのメッセージが表示されなかったバグの修正。
1.6.1.3オブジェクトの一種としてライト オブジェクトを追加。「平行」、「ポイント」、「スポット」光源に対応。
1.6.1.3オブジェクト ウィンドウに「ライト」タブを追加。ライト オブジェクトの設定に対応。
1.6.1.3デフォルト ライトの設定で、「平行」、「ポイント」、「スポット」光源に対応。
1.6.1.3デフォルト ライトおよびシーン全体のライトを設定する「ライト ウィンドウ」を追加。
1.6.1.3「シーン設定」ダイアログにあった「デフォルト ライト」の設定を「ライト ウィンドウ」に移した。
1.6.1.3デフォルト ライトの「環境光カラー」の項目名を「グローバル環境光」に変更。
1.6.1.3「デバイス」ダイアログに「頂点シェーダー」の「バージョン」、「光源処理」の表示項目を追加。
1.6.1.3「デバイス」ダイアログに「頂点シェーダーで汎用光源を使う」チェックを追加。これがOFFの場合、頂点シェーダーの描画で平行光源のみを使用可能。
1.6.1.3FBXファイル、Colladaファイルの入出力でライト オブジェクトに対応。
1.6.1.3FBXファイル、Colaldaファイルの入出力で「ライトの方向を調整」オプションを追加。ライト方向のコンバートに対応。
1.6.1.3FBXファイルの読み込みで「文字コードをUTF-8形式から変換」オプションを追加。UTF-8形式からの変換が選択できるようになった。
1.6.1.3FBXファイルの書き出しで「文字コードをUTF-8形式に変換」オプションを追加。UTF-8形式への変換が選択できるようになった。
1.6.1.3関連ヘルプ ドキュメントを更新。
1.6.1.3ToyStudio SDKで、カメラ、ライトのデータ入出力に対応。
1.6.1.3ToyStudio SDKのオブジェクトのクリエイト関数でカメラ、ライトに対応。
1.6.1.3ToyStudio SDKの「SamplePlugin」サンプルでカメラ、ライトのデータの入出力に対応。
1.6.1.3ToyStudio SDKの関連HTMLドキュメントを更新。
1.6.1.2Mayaで「リジッド スキニング」でスキニングされ、エクスポートされたFBXファイルのボーン データが正常に読み込めない不具合を修正。
1.6.1.2Mayaでオブジェクト単位(ポリゴン単位でなく)でマテリアルをセットされ、エクスポートされたFBXファイルのマテリアル データが正常に読み込めない不具合を修正。
1.6.1.2「デバイス」ダイアログの「ウィンドのZバッファーを共有」がONの場合、3Dウィンドウ上でドラッグしたときの選択矩形が表示されない不具合を修正。
1.6.1.1mpoファイルの読み込み時に、テクスチャ ファイルが読み込めなくなっていたバグを修正。
1.6.1.1FBXファイル入出力におけるテクスチャ ファイル名について「FileName」ではなく、「RelativeFileName」を利用するように修正。
1.6.1.1Xファイル出力オプションに「出力スケール」を追加。
1.6.1.1「オプション」ダイアログの「全般」タブの「ファイル(.toy)読み込みスケール/座標系の調整」の設定がアプリの再起動時に保持されないバグを修正。
1.6.1.0MQO、DXF、OBJ、3DS、DAE、FBXファイルの入出力において、座標軸の指定およびスケーリングに対応。
1.6.1.0「オプション」ダイアログの「全般」タブに「ファイル(.toy)読み込みスケール/座標系の調整」を追加。TOYファイルの読み込み時に座標軸やスケーリングの調整ができるようになった。
1.6.1.0「オプション」ダイアログ上でF1キーでヘルプが起動できないバグを修正。
1.6.1.0DXFファイル出力でZ軸がアップ方向になっていた不具合を修正。
1.6.1.03DSファイル出力でX軸が反転していた不具合を修正。
1.6.1.0「シーン ウィンドウ」が「表示」メニューからのクリックで表示できないバグの修正。
1.6.1.0使用しているFBX SDKを「2010.0.2」から「2010.2」へバージョン アップ。
1.6.1.0FBXファイル入出力におけるピボットの扱いを改良。
1.6.1.0「複製」コマンドで「対称方向」がOFFの場合、表示属性のないグループ等が複製されなかったのを複製されるようにした。
1.6.1.0テクスチャのアルファの「Modulate2X」~「SubTexture」が機能しないバグを修正。
1.6.1.0テクスチャのヘルプを詳しく記述した。
1.6.1.0「テクスチャ」ダイアログ上でF1キーでヘルプが起動しないバグを修正。
1.6.1.0アニメーションのインポート機能で、拡張機能の対応フォーマットとして「.fbx」、「.dae」、「.3ds」ファイルがダイアログやヘルプに明記されていなかったのを修正。
1.6.1.0モデルやアニメーションのインポート機能において、シーン関連のアニメーション キーが存在するファイルをインポートするとソフトが落ちるバグを修正。
1.6.1.0「アニメーションのインポート」ダイアログの「インポートするアニメーション キー」に「シーン」を追加。関連するヘルプなども更新。
1.6.1.0ポリラインのみで構成されたオブジェクトをXファイルにエクスポートすると、Xファイル ビューアー等で表示されないことがあるバグを修正。
1.6.1.0プラグインによるファイル入出力において、同一拡張子の場合、アプリ側機能よりも優先するように修正。
1.6.0.9「オブジェクト」メニューに「ミラー ポーズ」コマンドを追加。ボーンのミラー対称ポーズに対応した。
1.6.0.9「オプション」ダイアログの「全般」タブに、アニメーション キーの追加/削除時にグラフ ウィンドウを表示するかどうかのチェックを追加。
1.6.0.9アニメーションの新規作成時に、追加されたアニメーションをカレントにするようにした。
1.6.0.9「スムーズ スキニング」におけるボーン ウェイトの計算処理において、不正な極大/極小値が出ないようにした。
1.6.0.9「バインド ポーズ」コマンドで、ボーンを参照する「アタッチ」タイプのIKが実行されないようにした。
1.6.0.9ボーンの直接回転の際に、SHIFTキーでの選択追加がされるようにした。
1.6.0.8複数のIKハンドルが親子の階層にある場合、親IKが移動、回転などした時に子IKが実行されないバグを修正。
1.6.0.8マニピュレータの各ハンドルがカーソルの矩形エリア全体にヒットしないバグを修正。
1.6.0.8MQOファイルの「tex("")」(空のテクスチャ ファイル名)の記述で読み込みエラーを起こさないように修正。
1.6.0.8ゴースト表示をIKに対応させた。
1.6.0.8ゴーストをA、Bの2個とし、個別にキー フレームのオフセットを設定できるようになった。
1.6.0.8「シーン ウィンドウ」を追加し、シーン全体におけるゴーストのON/OFFやキー フレームのオフセットを設定できるようになった。
1.6.0.8「シーン ウィンドウ」の「シーン情報」ボタンをクリックすると、シーン全体におけるオブジェクトやポリゴンの情報を表示できるようになった。
1.6.0.8オブジェクトの削除のアンドゥーにおいて、ゴーストの設定が復元されないバグを修正。
1.6.0.8アニメーション ウィンドウの「最初/最後のフレーム」という記述を「最初/最後のキー フレーム」に修正。
1.6.0.8ToyPlayerのファイル未オープン状態で、ボリュームが動かない、再生ボタンや時間表示がグレー表示にならないバグを修正。
1.6.0.8サウンド ウィンドウで、再生テスト用の項目を「再生テスト」グループで囲んで明確にした。
1.6.0.8Toyファイルのバージョンを17に更新。
1.6.0.7IKハンドルの「ツイスト角」に対応し、オブジェクト ウィンドウの「IKハンドル」タブに数値設定項目を追加。
1.6.0.7オブジェクト ウィンドウの「IKハンドル」タブに「極ベクトル」の数値設定項目を追加。
1.6.0.7オブジェクト ウィンドウの「IKハンドル」タブに「極ベクトルの球面線形補間」チェックを追加。これがONの場合、極ベクトルのアニメーションにおいて、球面線形補間される。
1.6.0.7アニメーション作成用のキー タイプとして「せん断X、Y、Z」、「可視」、「IKツイスト」、「IK極ベクトル」に対応。アニメーションの自由度が広がった。
1.6.0.7IKハンドルを直接ドラッグして移動できる「直接移動」モードを追加。選択系のツールで利用可能。
1.6.0.7ボーンを直接ドラッグして回転できる「直接回転」モードを追加。選択系のツールで利用可能。
1.6.0.7IKハンドルのツイスト円を直接ドラッグして回転できる「ツイスト回転」モードを追加。選択系のツールで利用可能。
1.6.0.7「ツール」メニュー → 「オプション」ダイアログの「表示」タブに、直接操作用の「インディケータ」の設定項目を追加。
1.6.0.7マウス カーソルのクリック ポイントが四角形になり、ポイント選択がやりやすくなった。「ツール」メニュー→ 「オプション」ダイアログの「表示」タブに「カーソル サイズ」の設定項目を追加。
1.6.0.7IKで制約されたジョイントは、回転ツールで回転できないようにした。
1.6.0.7「バインド ポーズ」コマンドで、IKが反映されなかった不具合の修正。
1.6.0.7「バインド ポーズ」などのオブジェクト関連コマンドの一部について、アンドゥーができなくなっていたバグの修正。
1.6.0.7アニメーション キーが設定されたオブジェクトなどを選択した際に、グラフ ウィンドウの左側のツリー ペインの各項目の+/-表示の更新が更新されなかったバグの修正。
1.6.0.7「アニメーション キーの貼り付け」ダイアログに「シーン」の「コピー データ」の項目を追加し、シーン関連のキーの貼り付けの選択ができるようになった。
1.6.0.7SDKで「せん断X、Y、Z」、「可視」のアニメーション キーに対応。
1.6.0.7SDKドキュメントにおいて、マニュアル→スキニング→「スキニングのコード」の項目を追加。
1.6.0.7SDKのCTaAnim::AnimateObjectItem()関数が常にTA_ANIM_ITEM_SCALE_Xタイプのアニメーションを実行してしまうバグの修正。
1.6.0.7FBXファイルの入出力で、オブジェクトの「可視」フラグのアニメーションに対応。
1.6.0.7Xファイル、FBXファイルのスキニング対応データの出力において、ボーンのウェイトが全て0の頂点についての出力データがおかしくなっていた不具合の修正。
1.6.0.7タイムライン バーのキータイプ ボタンを大きくしてクリックしやすくした。
1.6.0.7Toyファイルのバージョンを16に更新。
1.6.0.6オブジェクト ウィンドウのメッシュ タブに「シェーディング」グループを追加。「スムーズ角度を指定」チェックがONの場合、面の相互角度から境界のスムーズ/フラット シェーディングが自動設定されるようになった。OFFの場合、これまでのように「スムーズ シエーディング」/「フラット シエーディング」 ツールでマニュアル設定が可能。
1.6.0.6mqoファイルのオブジェクトの「スムージングを適用」およびその角度の読み込みに対応。
1.6.0.6mqoファイルのオブジェクトの「スムージングを適用」およびその角度の書き込みに対応。
1.6.0.6「スムーズ シエーディング」/「フラット シェーディング」 ツールでのシェーディングの設定において、これまではポリゴン内の頂点についてスムーズ/フラットにするように設定していたが、ポリゴンの境界の辺に対して設定するように変更した。
1.6.0.6オブジェクト ウィンドウのメッシュ タブの「再分割曲面」グループに、「フラット シェーディング」チェックを追加。再分割曲面のスムーズ/フラット シェーディングを指定するようにした。
1.6.0.6objファイルの読み込みで、リンクされたmtlファイルの読み込みに失敗するバグの修正。
1.6.0.6オブジェクトを新規作成したとき、オブジェクト パネルの「+」/「-」表示が更新されない場合があったバグを修正。
1.6.0.6toyファイルの四角を超えるポリゴンの読み込み/書き込みバグの修正。
1.6.0.6ToyPlayerで、左手用に設定されたマウスでも視点操作が適正になるように修正。
1.6.0.6ToyStudioおよびToyPlayerで、右ボタン ドラッグ + 「SHIFT」キーで視点の平行移動に対応。ノート ブックPC等での操作を想定。
1.6.0.6オブジェクト ウィンドウのメッシュ タブの「スキニング」グループに表示していたボーン情報を「メッシュ情報」内で表示するように変更。
1.6.0.6再分割曲面が設定されたオブジェクトを削除しアンドゥーすると、再分割曲面設定が復元されないバグを修正。
1.6.0.6オブジェクト ウィンドウの「メッシュ情報」、アニメーション ウィンドウの「アニメーション情報」のポップアップ ウィンドウをAlt+F4キーで閉じると再表示できなくなる不具合の修正。
1.6.0.6ToyStudio SDKにおいて、CTaObject::SetFaceVertexColors()が、内部的にCTaObject::SetFaceVertexFlatShades()と同じ動作をするバグの修正。
1.6.0.6ソフトウェアで使用する用語において「シェード」を「シェーディング」に統一。「テクスチャー」を「テクスチャ」に統一。「アルファー」を「アルファ」に統一。
1.6.0.5オブジェクト ウィンドウのメッシュ タブに「メッシュ情報」ボタンを追加。クリックすると、頂点数やポリゴン数などの情報が表示できるようになった。
1.6.0.5アニメーション ウィンドウに「アニメーション情報」ボタンを追加。クリックすると、キータイプごとのキー フレーム数やデータ範囲などの情報が表示できるようになった。
1.6.0.5MQOファイルの読み込みで、ポリゴン等の図形要素が空のオブジェクトはヌル オブジェクトとして読み込むようにした。
1.6.0.5ヌル ツール等で図形を入力中に3D ウィンドウからフォーカスが外れると、ツールでの入力が中止されたりフリーズしたりするバグの修正。
1.6.0.4MQOファイルの視点情報の読み込み処理のバグを修正。
1.6.0.3カメラ パラメータの設定をカメラ ウィンドウではなく、オブジェクト ウィンドウで行うように変更。
1.6.0.3オブジェクト パネルで「ENTER」キーでオブジェクト ウィンドウを表示するようにした。
1.6.0.3オブジェクト パネルで表示属性のあるオブジェクトにチェック ボックスを追加し、オブジェクトの可視/不可視が一覧できるようになった。切り替えは「SPACE」キーでも可能。
1.6.0.3オブジェクト パネルのオブジェクトのチェック ボックスの右下に「L」(ロック)マークを追加し、編集不可/編集可が一覧できるようになった。切り替えはSHIFT+SPACEキーでも可能。
1.6.0.3オブジェクト パネルの右クリック メニューに「編集不可」を追加し、編集可/編集不可の切り替えができるようにした。
1.6.0.3オブジェクト パネルの右クリック メニューに「以下を設定」サブメニューを追加し。クリックしているオブジェクト以下全てについて、「選択/非選択」、「可視/不可視」、「編集不可/編集可」を一括設定できるようになった。
1.6.0.3オブジェクト パネルでのオブジェクトのドラッグ移動において、不要な場合でもオブジェクト名が変更される不具合の修正。
1.6.0.33Dウィンドウを常に最大化して開いてしまう場合があったバグの修正。
1.6.0.3「表示」メニューで非表示になっているタイプのオブジェクトが3Dウィンドウで選択できるバグの修正。
1.6.0.3視点の位置や射影タイプをTOYファイルに保存するようにした。
1.6.0.3「表示」メニューの表示項目をTOYファイルに保存するようにした。
1.6.0.3「表示」メニューに「表示項目をデフォルトに戻す」コマンドを追加。
1.6.0.3「オブジェクト ウィンドウ」、「マテリアル ウィンドウ」など、各種フローティング ウィンドウの表示状態を保持するようにした。
1.6.0.3「SHIFT」キーを押した状態でToyStudioを起動すると、パネルやウィンドウの表示状態がリセットされるようにした。
1.6.0.3「グラフ ウィンドウ」、「UVウィンドウ」、「カメラ ウィンドウ」が最小化されている場合、再度表示させる場合は通常表示に戻すようにした。
1.6.0.3MQOファイル出力で、「頂点カラーを出力」、「三角形化」のオプションを追加。
1.6.0.3MQOファイル出力で、マテリアルがセットされていないポリゴンの出力データの書式がおかしくなっていたバグの修正。
1.6.0.3MQOファイル読み込みで、視点の位置や射影タイプに対応。
1.6.0.3FBXファイル出力で、「三角形化」、「頂点あたりの最大ボーン数」のオプションを追加。
1.6.0.3FBXファイル出力で、「テクスチャ」オプションを追加。
1.6.0.3FBXファイル読み込みで、テクスチャ付きの一部のファイルの読み込みで落ちる不具合の修正。
1.6.0.3Xファイル出力で、「頂点あたりの最大ボーン数」オプションの追加。
1.6.0.3「ユーザー登録」ダイアログに「登録解除」ボタンを追加し、ユーザー登録を解除できるようにした。
1.6.0.3「表示」メニューの「アニメーション中は面のみを表示」がONの場合、タイムライン バーのドラッグ後などに面以外が表示されない場合があったバグを修正。
1.6.0.3「表示」メニューの「アニメーション中は面のみを表示」を連番BmpやAVIの出力時においても有効にした。
1.6.0.3Vista以前のOSで、「開く」ダイアログなどのタイトルの文字列が日本語化されないバグの修正。
1.6.0.3ToyStudio SDKをバージョンアップ(ドキュメントを更新)。
1.6.0.3ToyStudio SDKのバージョンをToyStudio本体と一致するようにした。
1.6.0.2ToyStudio Advanceの試用ライセンスおよびインターネット認証に対応。
1.6.0.2「表示」メニューに「視点の回転中心をセット」(F7キー)コマンドを追加。
1.6.0.2「表示」メニューの項目が多すぎたので子項目に分けた。
1.6.0.2F6キーでグラフ ウィンドウの左右のペインにフォーカスが移動するようにした。
1.6.0.2ヘルプの「ウェイトペイント」ツールの内容が古かったので更新。
1.6.0.2関連する機能のヘルプの更新、「拡張機能」についての内容を加筆。
1.6.0.1Windows Vista環境でToyStudio Advanceのオブジェクト選択用の矩形(点線)が表示されないバグを修正。
1.6.0.0メタセコイア ファイルの頂点カラーがうまく読めない場合があったバグの修正。
1.6.0.0メタセコイア ファイル出力で、頂点カラーに対応。
1.6.0.0オブジェクト ウィンドウの「ジョイント」タブで、「親ジョイントのスケールを修正」チェックを追加。
1.6.0.0拡張機能としてファイル入出力プラグイン機能を追加。アプリケーション フォルダの「Plugins」フォルダにプラグイン ファイル(.tll)をセットすると、起動時に読み込まれるようになった。
1.6.0.0拡張機能として「ツール」メニューに「プラグイン」ダイアログを追加。プラグインの有効化/無効化やプロパティの表示などに対応。
1.6.0.0ToyStudioに拡張機能を付加したシェアウェア版パッケージ ソフトとして「ToyStudio Advance」を追加した。
1.6.0.0プラグイン作成用のSDKとして、「ToyStudio SDK」を追加した。
1.5.0.73D ウィンドウにおけるキーボードの「↑」「↓」等のキーによる選択の移動がおかしくなっていたバグを修正。
1.5.0.73D ウィンドウにおけるキーボードの「↑」「↓」等のキーによる選択の移動で、押し下げ保持による連続入力に対応。
1.5.0.73Dウィンドウでオブジェクトを選択する際に、フォーカスが他のウィンドウへ移動するバグを修正。
1.5.0.6「シーン設定」ダイアログの「表示」タブで、「デフォルトライト」のスライダーの動作がおかしいバグを修正。
1.5.0.63Dウィンドウにおいて、ポイント選択されにくくなっていたバグを修正。
1.5.0.5FBXファイルのインポートで、読み込みファイルのPreRotation等の値が回転値に反映されないバグを修正。
1.5.0.4アプリケーションのインストールに、インストーラーを使用するようにした。
1.5.0.4Windows Vistaに正式対応。
1.5.0.4Windows Vistaにおける、UVウィンドウ、選択矩形の表示の乱れなどを修正。
1.5.0.4スムーズ スキニングで、影響範囲外の頂点にウェイトがセットされることがあるバグを修正。
1.5.0.4「移動」、「回転」等のツールで左ボタンドラッグ中に、右ボタンをクリックすると動作がおかしくなり、アンドゥーもできなくなるバグの修正。
1.5.0.4OSのコンテキストメニューの「新規作成」で、ToyStudioファイルに対応。
1.5.0.4ToyStudioおよびToyPlayerの「オプション」ダイアログで、拡張子の関連付け機能を追加。
1.5.0.4タイムラインバーの「キーセット ボタン」を他のボタンよりも大きめにした。
1.5.0.4FBXファイル入出力用SDKを更新(FBX SDK 2010.0.2)。このSDKはdae、3ds、objファイルの入出力についても利用しているので、入出力のバグなどが修正されている可能性あり。
1.5.0.4FBXファイル出力で、ファイルバージョンの選択ができるようになった。
1.5.0.4FBXファイル入出力で複数レイヤーのテクスチャーに対応。
1.5.0.4再生ソフトの拡張子がToyStudioのものと似ていてわかりにくかったので、「.top」に変更。再生ソフト名も「ToyPlayer」に変更。
1.5.0.3AVI、連番Bmp、連番Mqo、Waveファイルのエクスポートで、IKが反映されなかったバグを修正。
1.5.0.2IKシステムを変更。IKハンドルがオブジェクトの一種として操作できるようになった。
1.5.0.2選択モードに「極ベクトル選択 モード」を追加。回転面IKの極ベクトルをエディットできるようになった。
1.5.0.2「オブジェクト ウィンドウ」を項目ごとに展開可能なものに改良。
1.5.0.2「オブジェクト ウィンドウ」などで数値表示されている場合に、3Dウィンドウでのオブジェクト操作が遅延しないように改良。
1.5.0.2「オブジェクト ウィンドウ」に「IKハンドル」の項目を追加。
1.5.0.2マテリアル削除のアンドゥーでトゥーンシェーダの設定が復元されなかったバグを修正。
1.5.0.2UVウィンドウでの表示の拡大/縮小が効かなくなっていたバグを修正。
1.5.0.2ポリラインがあるオブジェクトについて、Fbxファイル出力に失敗するバグを修正。
1.5.0.23Dウィンドウにおけるポイント選択がシビアで、矩形選択になってしまう場合があったのを修正。
1.5.0.2IKハンドル ツールにおいて、ジョイントの選択に失敗すると、その後の選択がおかしくなるバグを修正。
1.5.0.2ウェイトペイント ツールの「ペイント値」に「-1」、「0」、「1」、「+/-」の入力ボタンを追加。
1.5.0.2ウェイトペイント ツール等のウィンドウで、F1キーでヘルプが表示されなかったバグを修正。
1.5.0.2オブジェクト パネルの右クリックメニューに「選択オブジェクトを表示」コマンドを追加。選択されているオブジェクトをツリー上で簡単に表示できるようになった。
1.5.0.2オプション ダイアログの「表示」タブで、全てのオブジェクトのタイプの色を設定できるように改良。
1.5.0.2オプション ダイアログの「一般」タブで、「最大IK計算回数」の項目を追加。
1.5.0.2Mqoファイルの頂点カラーを読み込むように改良。
1.5.0.2Xファイルの出力オプションで、「頂点カラーを出力」、「頂点カラーの最適化」を追加。
1.5.0.2Xファイルの出力オプションで、「IKをアニメーションに反映」、「IKハンドルをアタッチ」を追加。
1.5.0.2Xファイルの出力で、フラット/スムーズ シェーディングの法線ベクトルの最適化のバグを修正。
1.5.0.2Fbxファイルの出力オプションで、「IKをアニメーションに反映」、「IKハンドルをアタッチ」、「IK出力周期」を追加。
1.5.0.2タイムライン バーの「キータイプ ウィンドウ」の「関連オブジェクト」カテゴリーに「子オブジェクト」を追加。選択オブジェクトの子オブジェクト全体に簡単にキーをセットできるようになった。
1.5.0.2タイムライン バーの「キータイプ ウィンドウ」の「オブジェクト」カテゴリーに「IKアクティブ」を追加。
1.5.0.2タイムライン バーの「キータイプ ウィンドウ」の「関連オブジェクト」カテゴリーに「IKチェーンの回転XYZ」を追加。IKハンドルにリンクされている各ジョイントの回転キーを簡単にセットできるようになった。
1.5.0.2オブジェクトの「せん断」がXファイルなどの右手座標系の形式ににうまく出力されてなかったバグの修正。
1.5.0.2ジョイントの描画処理を軽量化。
1.5.0.2追加された機能のショートカット キーを追加。
1.5.0.2ToyファイルのダブルクリックでToyStudioを起動した場合、シーンを新規作成しないように改良。
1.5.0.1アニメーション付きXファイルの2個目以降のアニメーションの先頭フレームのデータがおかしくなる場合があるバグを修正。
1.5.0.1アニメーション付きXファイルのデフォルトの「出力周期」を「1」に変更。
1.5.0.1連番Bmpファイルのデフォルトの「出力周期」を「1」に変更。
1.5.0.1連番Mqoファイルのデフォルトの「出力周期」を「1」に変更。
1.5.0.0カメラ機能およびカメラ切り替えアニメーションに対応。
1.5.0.0カメラのFBX形式での入出力に対応。
1.5.0.0「.toy」および「.tov」ファイルのバージョンを「11」に更新。
1.5.0.0オブジェクトを削除しアンドゥーすると、「オイラー角」の順番、「せん断」の値が復元されないバグを修正。
1.5.0.0グラフ ウィンドウのツリーペインで、サウンド チャンネル単位でクリックする場合、グラフ表示が更新されないバグを修正。
1.5.0.0マテリアル パネルのトゥーンシェーダの「輪郭線太さ」をスピンボタンで調整する場合、数値の精度が細かすぎになるバグを修正。
1.5.0.0「シーン設定」ダイアログで、「背景」のカラー、「グリッド」のカラーをシーン側に保持できるようにした。
1.5.0.0ボーンの影響範囲に「スムーズ シェード」、「フラット シェード」 ツールが利用できないバグを修正。
1.5.0.0ボーンの影響範囲に「ポリゴン」 メニューのコマンドが利用できないバグを修正。
1.5.0.0「編集」メニューの「コピー」、「切り取り」コマンドが、標準メッシュ以外のオブジェクトでも有効だったバグを修正。
1.5.0.0「編集」メニューの「貼り付け」コマンドで、ポリゴンのマテリアルを維持できるように改良。
1.5.0.0タイムライン バーの「キータイプ」ウィンドウにおいて、「移動」と「回転」の要素のみがデフォルトでONになるように変更。
1.5.0.0ToyStudioヘルプの「その他」の項目に「Tips」のページを追加。
1.5.0.0「ToyVideo」を「ToyVideoPlayer」とアプリケーション名を変更。アイコンも変更。
1.5.0.0ToyVideoPlayerで、再生用のアニメーション、カメラの選択ができるようになった。
1.5.0.0ToyVideoPlayerに「デバイス設定」ダイアログを追加。
1.5.0.0ToyVideoPlayerに「オプション設定」ダイアログを追加。
1.5.0.0ToyVideoPlayerに、状況依存ヘルプを追加。
1.4.1.0ジョイント ツールで「親ジョントの角度を調整」がONの場合、親ジョイントのY軸の方向が正確に画面方向を向くように修正。
1.4.1.0ヌルを作成した場合、「元に戻す」/「やり直し」の文字列が「ジョイントの作成」となっていたのを修正。
1.4.1.0Fbxファイルを読み込んで、toyファイルに保存すると、toyファイル内のアニメーションの対象がずれておかしくなるバグの修正。
1.4.0.9アニメーション キーが2個以下のファイルをCollada(.dae)ファイルでエクスポートし、それを開くとToyStudioが落ちるバグを修正。
1.4.0.9不正なマテリアル インデックスがセットされたFBXファイルを開いても、ToyStudioが落ちないように改良。
1.4.0.9FBX、Colladaファイル等のインポート/エクスポート機能で、アニメーション キーの傾きやタイプを忠実に変換するように改良。
1.4.0.9グラフ ウィンドウでの「傾き」のタイプを、選択された複数のキーについて設定できるように改良。
1.4.0.9グラフ ウィンドウでの「傾き」のタイプに、「ステップ ネクスト」を追加。
1.4.0.9アプリケーション アイコンの変更。
1.4.0.8エクスポート機能で、「tov」以外のフォーマットで出力できなくなっていたバグを修正。
1.4.0.8「bmp」ファイルのエクスポート機能で、連番出力ではない場合、「mqo」ファイルが出力されていたバグを修正。
1.4.0.8マテリアルがセットされてないポリゴンが表示されないバグを修正。
1.4.0.7オブジェクトのプロパティーに「ゴースト表示」を追加。アニメーションの前後のキー フレームのモデルを重ね合わせて表示できるようになった。
1.4.0.7オブジェクトのプロパティーに、「ポリライン表示」を追加。ポリゴン数が多い場合、比較的軽い表示が可能。
1.4.0.7「.toy」ファイル バージョンを「10」に更新。
1.4.0.7[.toy」ファイルで、マイナス値(不正)になっているボーン ウェイトを「0」として読み込むように修正。
1.4.0.6拡張機能で、スキニング データを含むCollada(.dae)ファイルの入出力に対応。
1.4.0.6ToyVideoのトラック バーに時間表示を追加。
1.4.0.6ToyVideoのファイルを「開く」ダイアログで、ファイルの種類を保持するようにした。
1.4.0.6ToyVideoで、2個目以降に開いたファイルの視点がリセットされないバグを修正。
1.4.0.6スキニングされた、ファイルバージョンの異なるtoyファイルを「シーンにインポート」しようとすると、不正終了するバグの修正。
1.4.0.6スキニングされたファイルを「シーンにインポート」した場合、「バインド ポーズ」コマンドやファイル保存で不正終了するバグを修正。
1.4.0.6テクスチャーファイルが存在しなかった場合にエラーメッセージを表示するようにした。
1.4.0.6サウンドファイルが存在しなかった場合のエラーメッセージを的確な文言に修正。
1.4.0.6実行ファイルのマニフェストをVistaのUACに対応。
1.4.0.6IKハンドルをクリア後、アンドゥーすると落ちるバグを修正。
1.4.0.5エクスポート ファイルにToyVideoファイル形式(.tov)を追加。再生ソフトとして「ToyVideo.exe」を追加。
1.4.0.5toyファイル、mqoファイルの読み込みで、不正な番号のマテリアルを読まないように修正。
1.4.0.5タイムライン バーにおいて、再生中にサウンドがシークできるように改良。
1.4.0.5タイムライン バーの各種ボタンのレスポンスの向上。
1.4.0.5「傾き」が「ステップ」の場合のアニメーション キーの算出データがおかしくなっていたバグを修正。
1.4.0.5アニメーションの再生中に、「連続再生」設定を反映できるように修正。
1.4.0.5「サウンド ウィンドウ」のマスター ボリュームが利かない場合があったのを改良。
1.4.0.4スキニングされてないモデルにトゥーン シェードを設定すると、表示が透明になるバグの修正。
1.4.0.4データ フォルダ(マイ ドキュメントToyStudio)にあるテクスチャー等の参照ファイルが読み込まれない場合があったバグを修正。
1.4.0.3「オプション」ダイアログについて、「最大アンドゥー回数」、マニピュレータの「サイズ」、「ハンドル調整倍率」がシーンに反映されなくなっていたバグを修正。
1.4.0.3「マテリアル」ウィンドウの「影2」カラーを変更しようとすると、「影1」カラーが変更されてしまうバグを修正。
1.4.0.2描画処理を改良したので、スキニング モデルの表示おけるボーン数の制限がなくなった。よって、「デバイス」ダイアログにおける「スキニング ボーン数」を超える大量のボーンが使用可能になった。
1.4.0.1使用しているDirectX SDKのバージョンをDirectX SDK August 2007 に更新。
1.4.0.1マテリアル ウィンドウでトゥーン シェーダに対応。
1.4.0.1グラフ ウィンドウでのアニメーション キーのコピー、貼り付けに対応。
1.4.0.1オブジェクト ウィンドウの「影響範囲有効」設定がファイルに保存されてなかったバグを修正。
1.4.0.1Mikoto形式Mqoファイルを読み込んだ場合のボーンのトップ オブジェクトを「グループ」から「ヌル」に変更。
1.4.0.1ハードウェア頂点処理の場合に、2個目以降のテクスチャー用のUV座標が設定されなかったバグを修正。
1.4.0.1オイラー角の順番が読み込み時に反映されず、3D ウィンドウの表示がデフォルトのXYZのままになってしまうバグを修正。
1.4.0.1スキニングされたキャラクターを削除し、アンドゥーするとアプリが落ちるバグを修正。
1.4.0.1toyファイルのバージョンを9に更新。
1.4.0.1グラフ ウィンドウでアニメーション キーを移動する場合、同じフレーム番号が重複する場合があったバグを修正。
1.4.0.1グラフ ウィンドウので、アニメーション キーを数値で範囲指定して選択できるようになった。
1.4.0.1表示メニューに「選択ジョイントのみ影響範囲を表示」オプションを追加。
1.4.0.1スムーズ スキニングで、ジョイントの影響範囲外の頂点にウェイトが付いてしまう場合があったバグを修正。
1.4.0.1アニメーション パネルで、キーボードの「Enter」キーでアニメーションの選択ができるようにした。
1.4.0.0「ポリライン ツール」の追加。ポリライン図形の作成、入出力に対応。
1.4.0.0ジョイントに影響範囲をセットできるようになり、「スムーズ スキニング」等のコマンドで、ボーンの影響範囲を利用できるようになった。
1.4.0.0Mikoto形式の「.mqo」ファイル、「.mkm」形式のアニメーションファイルを読み込めるようになった。
1.4.0.0「スムーズ スキニング」等のコマンドで、「影響範囲で近接ボーンを算出」オプションを追加。ジョイントの影響範囲で近接ボーンを割り出せるようになった。「近接ボーンからの接続をたどる」オプションは不要となったため廃止。
1.4.0.0「スムーズ スキニング」等のコマンドで、「影響範囲でボーンのウェイトを算出」オプションを追加。ジョイントの影響範囲でウェイトを算出できるようになった。
1.4.0.0「スムーズスキニング」等のコマンドの処理速度を向上。選択されてないボーンの親ボーンのウェイトの算出がおかしくなるバグの修正。
1.4.0.0「オブジェクト ウィンドウ」に「影響範囲有効」オプションを追加。既存のジョイントの有効範囲を計算上無効にすることが可能。
1.4.0.0各種メッセージ ボックスがウィンドウの前面に表示されないことがあったバグを修正。
1.4.0.0「シーン設定」ダイアログを更新し、デフォルト マテリアルの設定に対応。
1.4.0.0環境光カラー、デフォルト ライト、デフォルト マテリアルをファイルに保持するようにした。
1.4.0.0「ウェイトペイント ツール」に「階層名で表示」オプションを追加。ボーン リストを階層名で表示するかどうかのの切り替えが出来るようになった。
1.4.0.03D ウィンドウにおいてキーボードの「↑」「↓」「←」「→」キー(上下左右方向)、「PageUp」「PageDown」キー(奥、手前方向)で、オブジェクト選択の移動が出来ようになった。
1.4.0.0[アニメーション パネル」でアニメーションをダブルクリックすることで、アニメーションを選択できるようになった。
1.4.0.0「オブジェクト パネル」のプルダウン メニューに「以下を展開」、「以下を閉じる」を追加。ツリーの開閉が一括して出来るようになった。
1.4.0.0「タイムライン バー」のGUIやショートカットを使った操作ににおいて、「SHIFT」キーを押した状態でフレーム番号の移動を行うと、現在の姿勢を保持したままフレーム番号のみを移動できるようになった。
1.4.0.0アプリケーション アイコンを更新。
1.3.0.8Xファイルの出力機能を最適化。
1.3.0.8Xファイルの出力オプションとして、「頂点とUVの共有」を廃止し、「法線ベクトルの最適化」、「UV座標の最適化」、「ルートおよびスキンメッシュのアニメーションを出力しない」を追加。
1.3.0.8「表示」メニューに「IKハンドル」の表示/非表示を追加。
1.3.0.8「ポリゴン」メニューの全サブメニューについて、「ポリゴン選択 モード」以外でも利用できるようにした。
1.3.0.8「スムーズシェード ツール」、「フラットシェード ツール」を、頂点、辺単位、面単位で利用できるようにした。
1.3.0.8.toyファイルのバージョンを「7」に更新。
1.3.0.8.dxfファイルが入出力できなくなっていたのを修正。
1.3.0.7IKハンドルに、末端のジョイントの方向を維持するための「アンカー」を追加。
1.3.0.7IKハンドルの有効/無効をポイント クリックのみで切り替えるようにし、オブジェクトの選択とは無関係にした。
1.3.0.7IKハンドルのカラーを設定可能にした。
1.3.0.7「名前をつけて保存」で非対応ファイル形式で保存しようとするとアプリが落ちる不具合を修正。
1.3.0.6マルチサンプリングをサポートするビデオカードの3D機能が利用できなかった不具合を修正。
1.3.0.6ジョイント ツールの「親ジョイントの角度を調整」をデフォルトでOFFに変更。
1.3.0.5マテリアル パネル、サウンド パネルで矢印キーによる選択ができるように改良。
1.3.0.5オブジェクト ウィンドウに「せん断」パラメータを追加。
1.3.0.5ボーン データの保持方式を、「ルート ボーン」を保持する方法から、個別のボーンを保持する方式へ変更し、関連する内部構造を更新。
1.3.0.5「スムーズ スキニング」ダイアログの更新
1.3.0.5「ボーンのウェイトをセット」コマンドを改良し、「ボーンの追加/ウェイトの再セット」に更新。
1.3.0.5「ボーンのウェイトを削除」コマンドを改良し、「ボーンを削除」に更新。
1.3.0.5「ボーンにリンク」コマンドを改良し、「ボーン参照をセット」に更新。
1.3.0.5「ボーンのリンクをクリア」コマンドを「ボーン参照をクリア」に変更。
1.3.0.5「.obj」ファイルのマテリアル(.mtl)読み込みを改良。「.dxf」ファイル読み込みモジュールを更新。
1.3.0.5「.toy」ファイルバージョンを6に更新。
1.3.0.5各種オブジェクトの作成時のオブジェクト名を、デフォルトでツリー全体でユニークになるようにした。
1.3.0.5各種オペレーションの途中で、作成したオブジェクトの角度がおかしくなることがあったバグの修正。
1.3.0.5拡張機能の読み込みファイル形式に「.fbx」「.dae」「.3ds」を追加。「.fbx」形式では、マテリアル、テクスチャー、アニメーション、スキニング全般に対応。
1.3.0.5拡張機能の「.x」ファイル書き込みオプションに「要素名をリネーム」チェックを追加し、元データの要素名をそのまま出力できるように改良。
1.3.0.5拡張機能の「.fbx」出力機能を改良し、マテリアル、テクスチャー、アニメーション、スキニング全般の出力に対応した。書き込みオプションに「頂点カラーを出力」「要素名をリネーム」チェックを追加した。
1.3.0.5拡張機能の書き込みファイル形式に「.obj」「.dxf」「.dae」「.3ds」を追加した。
1.3.0.4オブジェクトの属性に「回転を球面線形補間」を追加。回転のオイラー角の遷移が不連続なアニメーション データでも、再生時に表示が乱れなくなった。
1.3.0.43D機能を持たないビデオカードでも、リファレンス モードで起動できるようにした。
1.3.0.4オブジェクトの「編集不可」属性がファイルに保存されてなかったのを修正。
1.3.0.3アニメーションのインポート機能を追加。
1.3.0.3グラフ ウィンドウのツリーペインのサウンドの各要素の選択が更新されなかったのを修正。
1.3.0.3toyファイルのインポート時の、アニメーションのサウンド、オブジェクトへのリンクのバグを修正。
1.3.0.3bvhファイルの読み込みで、アニメーション全体の長さを読み込むように修正。
1.3.0.3背景カラー、グリッドカラーの設定を、オプション ダイアログに移動した。また、デフォルト背景カラー、グリッドカラーを白ベースに変更。
1.3.0.2印刷不可になっていたのを修正。
1.3.0.2アニメーション タイプ ウィンドウから対応ヘルプが呼べなかったのを修正。
1.3.0.2「ボーンのウェイトを削除」ダイアログで、ウィンドウを小さくしすぎると、ボタン等が表示されないバグを修正。
1.3.0.2「ウェイトペイント ツール」ウィンドウのボーンリストのエリアを拡大できるようにした。各ボーンの名称はルートからのフルパス名に変更。
1.3.0.2Mpoファイルのエクスポート機能で、「最初のフレーム」「最後のフレーム」が指定できるようにした。また、出力処理を中断できるようにした。
1.3.0.2Mqoファイルのエクスポート機能で、サウンド関連のキーフレームを参照しないように修正。
1.3.0.2Xファイルのエクスポート機能で、サウンド関連のキーフレームを参照しないように修正。
1.3.0.2連番ビットマップ、AVI、Waveファイルのエクスポート機能を追加した。
1.3.0.23D ウィンドウの「表示設定」ダイアログを追加。3D ウィンドウの表示サイズや視野角などを設定できるようにした。AVIファイルのエクスポート等で有用。
1.3.0.2「スムーズ スキニング」および「ボーンのウェイトをセット」ダイアログで「近接ボーンからの接続を優先」チェックを追加し、接近した部位のスキニング方法が選択できるようになった。
1.3.0.1Win2000世代のマシンでサウンド再生スレッドの優先度が低くて音が飛ぶことがあったので、優先度を上げた。
1.3.0.0Xファイルのエクスポート機能で、フレームあたりの時間分解能を指定できるようになった。
1.3.0.03Dウィンドウでのマウス右+左ボタンドラッグによるZOOMが不自然にキャンセルされる場合があったのを修正。
1.3.0.0「フレームレイト」、「開始フレーム」、「終了フレーム」、「現在のフレーム」を、シーン単位ではなくアニメーション単位で保持するようにした。
1.3.0.0ジョイント ツールのツール ウィンドウに、「親ジョイントの角度を調整」チェックを追加し、入力時に親ジョイントのX軸を子ジョイントに向けるかどうか選択できるようになった。
1.3.0.0スムーズ スキニングで通常のメッシュ オブジェクトをボーンとして使えるようになった。
1.3.0.0マテリアル ウィンドウのテクスチャーリストで、ドラッグによる順番の変更が可能になった。
1.3.0.0マルチテクスチャーを利用すると、2番目以降のテクスチャーがデバイスに保持されて表示がおかしくなってしまうバグを修正。
1.3.0.0マテリアルの削除をアンドゥーしたとき、テクスチャーが復元されなかったバグを修正。
1.3.0.0内容
1.3.0.0「グラフ ウィンドウ」のヘルプで、「傾き」メニューが「傾き」のポイントに対する操作ではなく「キー」のポイントに対する操作として記述されていた点を修正。
1.3.0.0テクスチャーファイルの読み込みダイアログで、jpg、gif、bmp以外の画像ファイル形式が表示できなかったのを修正。
1.3.0.0ファイルバージョンを4に更新。
1.3.0.0サウンド用のアニメーション キーのタイプとして「再生」、「ボリューム」を追加。
1.3.0.0サウンド機能、サウンドパネルの追加。
1.2.0.3「ボーンのウェイトをセット」ダイアログに「チェックされたボーンのみを算出」チェックを追加。これによって、チェックされたボーンのみについてウェイトを算出してセットできるようになった。
1.2.0.3オブジェクト パネルでオブジェクトをドラッグして移動するとき、「子にする」か「挿入」するかを「ダイアログ」ではなく、「ポップアップメニュー」で選択するように変更。
1.2.0.3オブジェクト パネルで、ルート オブジェクトに他のオブジェクトをドラッグして「挿入」しようとすると落ちる不具合を修正。
1.2.0.2「スムーズ スキニング」、「ボーンのウェイトをセット」、「ボーンのウェイトを削除」コマンドのダイアログで、「全てをチェック」、「全てを解除」ボタンを追加、ダイアログのリサイズおよびサイズの保持、前回のチェック内容の保持に対応。
1.2.0.2「ボーン ウェイトのセット」コマンドのアルゴリズムの細部を改良。
1.2.0.2「オブジェクト パネル」、「マテリアル パネル」、「アニメーション パネル」、「タイムライン バー」上で、F1キーで該当ヘルプ項目にジャンプしなかった不具合を修正。
1.2.0.2「アニメーション ウィンドウ」で該当アニメーション全体の「最初のフレーム」、「最後のフレーム」を表示できるようにした。
1.2.0.2Fbxファイル出力機能で、「XYZ」以外のオイラー角のタイプについての出力の不具合を修正。
1.2.0.1「スムーズ スキング」コマンドでウェイトをセットするボーンの選択、頂点のボーン数の設定が可能になった。
1.2.0.1「リジッド スキニング」の廃止。「スムーズ スキニング」で頂点のボーン数を「1」にすれば同じ動作が可能。
1.2.0.1「ボーンのウェイトをセット」コマンドを追加。スキニング済みのオブジェクトに対して、ボーン要素ごとに「スムーズ スキニング」同様のウェイト設定が可能になった。
1.2.0.1「ボーンのウェイトを削除」コマンドを追加。指定ボーン要素のウェイトの削除ができるようになった。
1.2.0.1IKの動作精度を修正。
1.2.0.1ユーザー登録コマンドで、起動するごとにライセンス キーの入力を入力する必要があったバグを修正。
1.2.0.1コマンド名称を変更:「スキンにリンク」→「ボーンにリンク」、「スキンをクリア」→「スキニングをクリア」、「スキンのリンクをクリア」→「ボーンのリンクをクリア」。
1.2.0.1ヘルプの「ボーンにリンク」コマンドの記述で、メッシュ オブジェクトの既存のボーン数を、リンクするボーン数『以上』に修正。
1.2.0.1オブジェクトの「再分割曲面」、「編集不可」設定でアンドゥー、レドゥーが利かなくなっていたバグを修正。
1.2.0.0ウィンドウへのダイレクト フォーカスやカレント フレーム移動等の、キーボード ショートカットキーの充実。
1.2.0.0F2~F5キーでの、正面、側面、上面等の3D表示切替に対応。
1.2.0.0タイムライン バーのスライダーをマウスの中央ボタン スクロールや←→キーで操作可能に。
1.2.0.0全ウィンドウについて、Tabキーでの入力項目移動、Space/Enterキーでのボタン押し下げに対応。
1.2.0.0BVHファイルの読み込みに対応。
1.2.0.0toyファイルバージョンを3に更新。
1.2.0.0グラフ ウィンドウの数値入力バーで相対座標に対応。
1.2.0.0アニメーションのスプライン関数のバグ修正およびパフォーマンス向上。
1.2.0.0カレント フレームの変更でアニメーション要素のアンドゥー情報をクリアしないように変更(アンドゥー/レドゥーの厳密化)。
1.2.0.0オブジェクトのオイラー角のタイプを設定可能に。
1.2.0.0スムーズ スキニングの頂点距離に対する減衰率を設定可能に。
1.2.0.0マニピュレータの中央ハンドルと他のハンドルの比率を設定可能に。
1.2.0.0グラフの角度表示がラジアンになっていたのを度に修正。
1.2.0.0Ikでボーンが180度逆の方を向くバグを修正。
1.2.0.0出力Mqoファイルでのカメラ方向を修正。
1.2.0.0デフォルトで、Zバッファーを共有OFF、高精度ZバッファーON、ハードウェア頂点処理をOFFに変更。
1.2.0.0デフォルトで、アニメーション中にボーンを表示するように変更。
1.2.0.0マニピュレータのデフォルトサイズを120に変更。
1.2.0.0グラフ ウィンドウ、UV ウィンドウの最大化/最小化対応。
1.2.0.0「ファイル」メニューの「最近使ったファイル」の数を16に変更。
1.1.0.6ヘルプを状況依存に改良。「ウェイト ペイント」ツール ウィンドウの改良。
1.1.0.5toyファイルの読み込みを高速化。
1.1.0.5UV ウィンドウの背景に、現在のマテリアルを表示するように変更。
1.1.0.5アニメーション キーのエディット時に、現在の姿勢をリセットしないように変更。
1.1.0.5アニメーション メニューの「全てのキーを削除」コマンドの追加。
1.1.0.5回転ツールのマニピュレータでのジンバルロックの防止。
1.1.0.5ヘルプファイルの追加。
1.1.0.4多くのデバイス環境で使えるよう改良。「デバイス」ダイアログにデバイスの設定機能追加。
1.1.0.3「バインドポーズの更新」コマンドを追加。
1.1.0.3Mikotoで出力したLF改行コードのMqoファイルを読めるように修正。
1.1.0.3連番付きMqoファイルの出力。
1.1.0.2ビデオカードの使用デバイスの状態確認用に、「デバイス」ダイアログを追加。
1.1.0.2「オブジェクト パネル」や「グラフ ウィンドウ」のツリー上で、キーボードの「↑↓→←」キーで要素の移動、「Enter」キーで要素の選択を出来るようにした。要素のダブルクリックで子要素が開閉しないように修正。
1.1.0.2「3D ウィンドウ」、「グラフ ウィンドウ」、「UV ウィンドウ」において、マウスの「右ボタン」+「左ボタン」ドラッグでズームできるようにした。
1.1.0.2ウェイト ペイント機能で、「表面をペイント」チェックボックスを追加。表面のみペイントするか、奥行きも含めるかの選択が可能になった。
1.1.0.2スキンオブジェクトとボーンについて、「スキンにリンク」する場合に、スキンオブジェクトのボーン数がリンクするボーン数以下ならば設定できるようにした。
1.1.0.2スキンオブジェクトに参照されたボーンの複製、追加、削除等を行った場合に、スキンオブジェクトのボーン参照をキャンセルしないようにした。
1.1.0.2ボーンのリンクを解除すると、スキンオブジェクトが表示されないバグの修正。
1.1.0.2Direct3Dの固定機能を使うデバイスでスキニング描画をしないバグの修正。
1.1.0.2ボーンとしてリンクされたジョイントについての「複製」のバグの修正。
1.1.0.2Metaseqファイルのマテリアルの"vcol"属性、頂点の"vertexattr"属性があるものを正常に読めなかったのを修正。
1.1.0.2再分割曲面のフリーズ形状がおかしくなっていたのを修正。
1.1.0.2「結合」コマンドの不具合を修正。
1.1.0.1メタセコイアファイルの「階層」("depth")への対応、ローカル座標解釈の修正。
1.1.0.1タイムライン バーの「手前のキー」「次のキー」ボタンが有効にならないバグの修正。
1.1.0.1「元へ戻す」コマンドのプロンプト文字列が「繰り返す」になっていたのを修正。
1.1ファイルのインポート機能を追加。
1.1読み込みファイル形式にWavefront(.obj)ファイルを追加。
1.1ネイティブファイル形式(.toy)ファイルのバージョンを2に更新。
1.1複数のアニメーションに対応。
1.1ファイル読み込み時の、シーンサイズ調整方法の修正。
1.1『表示』メニューに『ジョイント』の表示/非表示を追加。
1.1『オブジェクト』メニューに『スキンにリンク』、『スキンのリンクをクリア』コマンドを追加。
1.1ToyStudioにおける用語の『モード』を『ツール』に変更。
1.1UVウィンドウで0~1を超える範囲に対応。『表示範囲をフィット』、『表示範囲を標準化』、『テクスチャーを並べて表示』コマンドの追加。マウスの右ボタンでスクロール、中央ボタン回転でズーム表示に対応。
1.1Ver.1.0ではオブジェク名はツリー全体でユニークである必要があったが、Ver.1.1では兄弟オブジェクトでユニークであればよいように変更。よって、ツリー全体におけるオブジェクトの参照名は『ABC』になり、A、B、Cが同一名でOK。
1.1ツールのマニピュレータ表示サイズを『オプション』ウィンドウで設定可能になった。
1.1『マテリアル パネル』の表示のちらつきを解消。

コメントを残す

メールアドレスが公開されることはありません。